勤勤学长

共同成长,共同思考

解析免密码查任何人QQ业务成长值软件

上午在某网看到了这个软件,就好奇抓了一下包。给新手朋友分享一下过程和这个软件的原理。
《解析免密码查任何人QQ业务成长值软件》
过程开始

下载抓包工具WSExplorer

《解析免密码查任何人QQ业务成长值软件》

点击cha询得到包。
《解析免密码查任何人QQ业务成长值软件》
双击查看,发现他是通过他的网站进行查询,具体的业务查询接口并没有看到。
(之前我就做过这个业务查询软件,但是不小心格错盘就把源码删了,心酸)
浏览器打开链接
《解析免密码查任何人QQ业务成长值软件》
一个完整的业务 {“wording”:”QQ秀红钻贵族,全场10万件QQ秀免费穿,尽享全球最新潮流装扮服务。 “,”exp”:1,”level”:1,”percent”:0,”isVip”:0,”name”:”红钻”,”isOpen”:0}
wording 介绍
exp 经验值
level 等级
name 业务名称
isOpen 开通状态,1开通,0为开通
isVip 和  percent 不知道是说明,目前也没有分析的必要,因为已知都足够使用。
正则匹配 name”:”(.*?)”,”isOpen”:(.*?)}

《解析免密码查任何人QQ业务成长值软件》

 

.子程序 业务查询
.局部变量 网页源码, 文本型
.局部变量 正则1, 正则表达式类
.局部变量 a, 整数型
.局部变量 临时文本, 文本型

网页源码 = 编码_URL解码 (网页_访问s (“http://******/1.php?QQ=318692996”), 真)
正则1.创建 (“name” + #引号 + “:” + #引号 + “(.*?)” + #引号 + “,” + #引号 + “isOpen” + #引号 + “:(.*?)}”, 网页源码)
.计次循环首 (正则1.取匹配数量 (), a)
临时文本 = “业务名称:” + 正则1.取子匹配文本 (a, 1) + “,开通状态:” + 正则1.取子匹配文本 (a, 2) + #换行符 + 临时文本
.计次循环尾 ()
调试输出 (临时文本)

《解析免密码查任何人QQ业务成长值软件》

点赞